ICS Tutorials: Menus and Dialogs

Start Builder
Xcessory

Getting Started

In this tutorial, you will add several pulldown menus and several types of dialogs to the
address book. This will complete the principal elements of the interface.

Note: This tutorial assumes that you have chosen C as your language. The steps will be
somewhat different if you are using ViewKit or Java. Those differences will be discussed

in tutorials seven and eight respectively.

Before You Begin This Tutorial

e Make a new directory called t ut ori al _4 and change directories to
tutorial 4.

« Ifyou have not started Builder Xcessory yet, enter the following at the prompt in the
tutorial 4 directory:

% bx

Initialize your application as follows:

1. Clear the Builder Xcessory display by selecting New from the Main Window File
menu.
2. Open the UIL file you saved at the end of Tutorial 3:

<tutorial path>/tutorial_3.uil

Creating a Menu Bar

Before you create the pulldown menus, you must add a Menu Bar to the address book. To
add the Menu Bar, perform the following steps:

1. Use MB2 to select XmMenuBar from the Motif Menus group of the Palette.
2. Drag the XmMenuBar to the Browser and drop it onto the mai NW ndow node in
the tree. Builder Xcessory automatically places the menu bar across the top of the
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mai NW ndow. The XmMenuBar will be empty because you have not added any
menus to it yet! We’ll do that next.

Motif Menus

You will now add three pulldown menus to the address book: File, Edit, and Help.

To create the File menu, perform the following steps:

1. With MB2, select the XmPulldownMenu from the Palette and drop it onto the Menu
Bar in the interface.

'__,F Motif Menus

2| )|
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Note: When you create a PulldownMenu, Builder Xcessory actually creates 3 widget
instances: a CascadeButton, with an associated PulldownMenu, which parents a
PushButton. This hierarchy is reflected in the Browser.
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|— pushButtan

2. Ifyou have set the Auto Menu Popup toggle in the User Preference, the menu
initially appears posted (i.e., “popped-up”). To unpost the menu, unset Show Menu
Children in the Main Window View menu or press Ctrl/U, the keyboard accelerator
for that menu item.
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To change this default behavior, unset the Auto Menu Popup toggle in the Behavior tab
of the User Preferences dialog. The User Preferences dialog is accessed via the Options
menu choice in the Main Window.
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Adding Menu Items

Now you will add two more PushButtons and a Separator to the File menu. Perform the
following steps:

1. SelectcascadeButton by clicking MBI on the node in the Browser.
. Ifpul | downMenu is not already posted, post it by pressing Ctrl/U.
3. Use MB2 to drag an XmPushButton to the pul | downMenu on the interface.

Builder Xcessory automatically adds items you place on a menu at the bottom of the
menu.

_JI Maotif Primitives
(=D
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4.  Add an XmSeparator to the menu.
5. Add another XmPushButton to the menu.
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Naming Widget 6. Select cascadeBut t on in the Browser.
Instances 7. Change the Instance Name to f i | ePane.

ICS TUTORIALS
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8. Repeat steps 67 for each of the PushButtons, using the following names:

Object New Name
pushButton [fileOpen
pushButtonl |fileSave
pushButton2 |fileExit

Labeling File Menu Components

Now you will use the Resource Editor to add labels, accelerators, and mnemonics to the
File menu. To label the File menu header, perform the following steps:

1. Selectfil ePane.
2. Change the following resources, setting each storage location to App:
labelString | File App
mnemonic F App

Note: Here and in the following tutorials, set the resource storage location for any
displayed text to App. This will simplify internationalization in the future.

Note: Setting the mnemonic allows you to post the File menu by pressing Alt/F on the
keyboard.
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Similarly, set the following resources for f i | eOpen:
Resource Value Location
accelerator Ctri<key>O | App
acceleratorText |CtrH+O App
labelString Open... App
mnemonic O App
= L% E| [Elra

Setting the .. :
accelerator text -

forfil eQpen

5. Set the following resources for f i | eSave:

Resource Value Location
accelerator Ctri<key>S | App
acceleratorText |Ctri+S App
labelString Save App
mnemonic S App

6. Finally, set the following resources for f i | eExi t :

Resource Value Location

labelString | Exit App
mnemonic X App
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Status Check! Your interface should now appear like the figure below (remember to save your work in
thet ut ori al _4 directory before proceeding!)
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7. Selectfi | ePane again and hide the menu by pressing Crtl/U
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Using Keep Parent

Keep Parent makes it easier to add multiple children to a widget instance, especially
when that widget instance is a menu.

The Edit menu includes six PushButtons and a Separator. To add these elements, use the
steps in the following sections:

1. Add an XmPulldownMenu to the interface by dragging it to the menuBar using
MB2. The menu portion of your user interface should look like the image below.
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2. Select the Keep Parent toggle from the Main Window View menu.

Note: Only valid children for the selected object will be sensitive on the Palette.
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On the Browser, select pul | downMenul.
Add five XmPushButtons. Because Keep Parent is on, you can add items to the

interface simply by clicking on them in the Palette with MB1. Builder Xcessory
knows to parent the new object to the selected object.
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Moving a Menu 5. Add an XmSeparator to the interface. Click on XmSeparator on the Palette.
Item The Separator is at the bottom of the menu. To move it up to the correct spot,
perform the following steps:
6. Select separ at or 1 on the Browser tree.
7. Press Ctrl/R to raise the Separator one level. (Ctrl/L lowers the item one level.)
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8. Perform the raise operation three more times. separ at or 1 should now follow
pushBut t onl. Your menu should look like the following diagram.
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9. Unset the Keep Parent toggle on the Main Window View menu.

Setting Instance Names for Edit Menu Components

As always, using your own instance names when working with Builder Xcessory is a good
practice. Use the following table to assign new names for each of the objects in the Edit
menu.

Object New Name

cascadeButton [editPane
pushButton editNew
pushButtonl |editModify
pushButton2 |editCut
pushButton3  |editCopy
pushButton4 |editPaste
pushButton5 |editDelete

To change the Instance Name, perform the following steps for each object in the table
above:

1. Click on the instance name in the Browser to select it For example, click on
cascadeBut t on in the Browser to select it.

ICS TUTORIALS 11
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Then in the Resource Editor window, click on the text cascadeBut t on to the right

of the label “Instance Name”
Type the new name.
Click on the check mark at the end of the text field, or press Return.

Note: We set all the new names for the instances at once to avoid confusion. More

commonly, you will assign a new Instance Name as you tailor the other resources of an

object. We’ll use this more efficient approach in future tutorials.

Setting Resources for the Edit menu Components

Now you will use the Resource Editor to add labels, accelerators, and mnemonics to the

Edit menu. Tailor the Edit menu by performing the following steps:

1.
2.

ICS TUTORIALS

Select the edi t Pane instance of the cascadeBut t on in the Browser.
Change the following attributes and resources:

Resource Value Location
labelString Edit App
mnemonic E App

Similarly, set the following attributes for edi t New under pul | downMenul:

Resource Value Location
accelerator Ctri<key>N App
acceleratorText Ctr+N App
labelString New Entry...| App
mnemonic N App

Set the following attributes for edi t Modi f y under pul | downMenul:

Resource Value Location
accelerator Ctri<key>M App
acceleratorText Ctrl+M App
labelString Modify Entry...| App
mnemonic M App
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5. Set the following attributes for edi t Cut under pul | downMenul:

Resource Value  Location
accelerator Ctri<key>X| App
acceleratorText| Ctri+X App
labelString Cut App
mnemonic t App

Note: “C” is not available here, because mnemonics must be unique within a menu, and
“C” is used for Copy. “t” is the value suggested by the OSF/Motif Style Guide.

6. Set the following attributes for edi t Copy under pul | downMenul:

Resource Value  Location
accelerator Ctri<key>C| App
acceleratorText| Ctr+C App
labelString Copy App
mnemonic C App

7. Set the following attributes for edi t Past e under pul | downMenul:

Resource Value  Location
accelerator Ctri<key>P| App
acceleratorText| Ctr+P App
labelString Paste App
mnemonic P App

8. Set the following attributes for edi t Del et e under pul | downMenul:

Resource Value Location
labelString Delete App
mnemonic D App
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Note: There is no accelerator for the Delete function, since that would make a potentially
damaging action too easy.

Status Check The upper portion of your user interface should look like the sample below. You should
compare your object instance hierarchy displayed in the Browser to the sample below. If
they match, save your work and proceed!
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Structure of User Interface after setting resources for the Edit Menu
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Adding the Help Menu

The Help menu includes only a single PushButton. To add these elements, use the
following steps:

1. Add an XmPulldownMenu to the interface by dragging it to the menuBar using
MB2. Three objects—cascadeBut t on, pul | downMenu2, and
pushBut t on—appear on the Browser tree under nenuBar .
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2. Select cascadeBut t on in the Browser (if not already selected).

3. Inthe Resource Editor window, click on the text cascadeBut t on to the right of
the label “Instance Name”

4. Type the new name hel pPane.

5. Click on the check mark at the end of the text field, or press Return.
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Setting Help 6. Select menuBar in the Browser.
Button 7. Use the “Find” function of the Resource Editor to find the resource
menuHel pW dget . Enter hel pPane as the resource value.

16 ICS TUTORIALS
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Note: The help menu shifts to the far right edge of the Menu Bar.
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Now you use the Resource Editor to add labels to the Help menu. To label the Help menu
header, perform the following steps:

Labeling Help Menu Compents

1. Select hel pPane in the Browser.
2. Change the following resources:

Resource Value Location

labelString | Help App
mnemonic H App

3. Change the following resources for pushBut t on:

Resource Value Location
labelString [ About| App
mnemonic A App
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Status Check! The basic interface is now complete and should appear like the figure below. If it does,
now would be a good time to save your work.
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Creating Dialogs

To complete the interface, you will now add three dialog boxes: for File Open, Edit New
Entry, and Edit Modify Entry.

Motif provides a number of standard dialog widgets. For File Open, you will use a
FileSelectionBox.

1. Select Keep Parent by clicking on the View menu in the Main Window.

2. Select mai nW ndow in the Browser with MB1.

3. On the Palette, click (and release!) on the XmFileSelectionBox with MB1. If it is
grayed-out, then you do not have mai nW ndow selected.

_JI Motif Dialogs

m ==

E ¥mFileSelectionBoy

4. Move the outline of the XmFileSelectionBox to your user interface.
5. Drop the XmFileSelectionBox anywhere on your user interface using Ctrl/MB3.

Note: Understand that you are using a two button mouse combination here. You click and
release on the XmFileSelectionBox with MB1 and then move the outline over your user
interface. Then you use the Ctrl/MB3 combination to drop it onto your user interface.
The XmFileSelectionBox is named f i | eSel ecti onBox in the Browser tree. Using
Ctrl/MB3 instead of MB1 to drop the object on the interface automatically sets it for
“Natural Size,” and creates a di al ogShel | as well. You can only use this technique
to drag an object to the actual interface, not to the Browser tree (as you can with MB2).

ICS TUTORIALS 19
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Hiding an Object
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The fil eSel ect i onBox becomes the child of the object where you dropped it. It
overlaps the parent by default.

Warning: If you have not set Keep Parent and are not quite accurate in where you drop
the fi | eSel ect i onBox, it might be created as an unparented di al ogShel | . Since
it is not part of the main hierarchy tree, changes you make to the main tree, such as style
changes, will not propagate automatically to the di al ogShel | .

To hide fileSelectionBox, perform the following:

1. Selectthefil eSel ecti onBox.
2. Select Hide on the Resource Editor Component menu.
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Note: Hiding a user interface component performs two important functions. First it clears
up screen clutter and allows you to focus on particular portions of the user interface.
Second, when you generate code, “hidden” user interface components (typically dialog
boxes) are created, but not managed. This means that they will not be visible to the user
of your application until your code specifically manages them.

Adding a To add an “About” dialog for the Help menu, perform the following steps:

Message Box o . . )
1. Confirm that Keep Parent is still selected as in the prior section.

2. Select mai nW ndow in the Browser with MB1.

il Motif Dialogs

3| =2 =

= -ﬁm Messagebox

[98)

On the Palette, click (and release) on XmMessageBox with MB1.

Move the outline of the XmMessageBox to the interface.

5. Drop the XmMessageBox anywhere on your user interface using the Ctrl/MB3
combination as in the previous section. The XmMessageBox is named
messageBox in the Browser tree.

=
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6. Compare your widget hierarchy with the following figure to confirm that the
XmMessageBox was properly parented.
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Viewing The MessageBox is a compound object, consisting of a number of smaller objects. To
Compound view the makeup of the Message Box, select Show Compound Children on the Main
Children Window View menu. The Browser tree now displays the children of all compound objects

in the interface.
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Note: Children of a compound object are indicated by a red arrow on the Browser tree.
Builder Xcessory allows only limited modification of these children.
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Removing By default, the MessageBox contains three PushButtons labeled: OK, Cancel, and Help.
Unused buttons For the “About” dialog, only the OK button is required, so you should delete the others as
follows:

1. Select messageBox. Cancel on the Browser.
Select Hide on the Resource Editor Component menu. The Cancel button
disappears from the display and will not be included when you generate code.

HE D B S L daE e

Fnd e - i I

(98]

Repeat steps 1-2 for messageBox. Hel p.
4. To conceal the compound children, deselect Show Compound Children on the Main

Window View menu.
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Labeling the About  To add text to the about box, set the following attributes:
Box
© 1. Select messageBox in the Browser.
2. Inthe Resource Editor window, click on the text messageBox to the right of the
label “Instance Name”
3. Type the new name about Box.
4. Set the remaining resources for about Box according to the table below.
(Remember to set the resource placements to App!).

Resource Value Location
dialogTitle Help About App
messagesString | Address Book 1.0 App
okLabelString OK App

5. Select About Box in the Browser
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The aboutBox should be like the figure above

6. Select Hide on the Resource Editor Component menu

Customizing a You can customize the standard dialog boxes to create dialogs specific to your
Dialog application.

To create a customized dialog box, perform the following steps:

1. Click on XmMessageBox in the Palette with MB1.
Use Ctrl/MB3 to place the XmMessageBox in the interface. (Remember to make sure
Keep Parent is selected and that you have mai nW ndowselected in the Browser!)
This MessageBox is named nessageBox on the Browser tree.

Note: Since this is the second MessageBox you have added, it would normally be named

nmessageBox 1. However, you have already renamed the first MessageBox to
about Box.

3. Select tessageBox if it is not already selected.
4.  Set the Instance Name to ent r yBox in the Resource Editor.
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5. Setthe di al ogType to XmDIALOG TEMPLATE.
6. Set storage location to Code (not App!).

Canmpomrt Vew  Cablon

oS 3% B B

miling Mami | TS o, WORKING . ]
s Hame srndeiiaoel s _DInDIRIOS WARNING
Styla S O QUEETIOM
EmDIADG MESSRE
_penbiGs_ SO AT IO |
dlakasiyie |_ orm |
_ MO _FERDS |
Wilog Tikey [ [membugc TEsplare ] M= =]
sk Type Wil O TEHPLA ﬂ = Cmis -|
: - e mw I
Flad Eeoanos I ] LN

By default, the XmMessageBox contains three PushButtons labeled: OK, Cancel, and
Help. When you reset the di al ogType resource, those buttons disappear, and the
dialog is blank.

You will now create a dialog box for making an address book entry. To add the necessary
text entry fields, perform the following steps:

1. Selectent ryBox (keep focus)
2. Place an XmRowColumn in ent r yBox.
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3. Place an XmFrame in r owCol umm.
4. Add an XmLabel to f r ane.
B [ entryBox
— = Il'---.al.'.-. Ufn

| .?I|_||j|rr.um-i

labe

Note: Because f r ane is so small in the interface, it is easier and more reliable to add the
XmLabel on the Browser, or by setting Keep Parent on f r ane.

4. Set the following resources for | abel :

Resource Value Location
childHorizontalSpacing 0 Code
childType XmFRAME_TITLE_CHILD Code
childVerticalAlignment | XmALIGNMENT_WIDGET_BOTTOM| Code

5. Addan XmTextField to f r ane.
6. Set the following resources for t ext Fi el d:

Resource Value Location
childHorizontalSpacing 0 Code
childType XmFRAME_WORKAREA_CHILD Code
childVerticalAlignment | XmALIGNMENT_WIDGET_BOTTOM| Code
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Status Check! At this point, your user interface and widget hierarchy should look like the examples
below. If they do, now would be a good time to save your work.
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Copying an object The following is best done using the Browser:

Adding a 1. Place a second XmFrame (f r amel) on the r owCol umm in the interface.
second frame 2. Copyl abel intofranel. Select| abel with Ctrl/MB2, drag itto framel. The
Ctrl modifier causes Builder Xcessory to make a copy rather than reparent the object.
3. Add an XmScrolledText to f r anel.
4. Add two more XmFrames to r owCol umrm by copying f r ane twice.

Select Ctrl/MB2, and drag it to r owCol umm. This retains all the constraints and
resources of frame and its children.

Since the last two items have the same structure as the “address” entry area
(ent r yFr ane), you can reuse the work you did to format that one.

% [ 3 mesw gees meees gese
T S8 tUBCl FEOB FE

Your user interface and
widget hierarchy should
look like this
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Note: You may have to use your window manager to adjust the size of the Entry Editor to
achieve the layout in the previous illustration

Labeling the Entry Label the four entry areas in the address Entry Editor by using an extended editor, as
Editor Dialog follows:

US{'ng extended Note: Using an extended editor allows you to set a resource in several objects without
editor updating the Resource Editor.

1. Selectl abel inthe Browser.

2. Open the extended editor for the | abel Stri ng resource.

3. Enter the label Nane. Click on the entry area, and then type in Name to replace the
previous data (in this case the default text “label”).

4. Select the App resource placement option.

5. Click on Apply. Leave the extended editor open.
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6. Repeat steps 1-5 to set the | abel Stri ng resource for the following objects:

Object labelString Location

label4 Address App
label5 Phone App
label6 E-Mail App

7. Dismiss the extended editor.

Adding Control To add control buttons to the address Entry Editor dialog, perform the following steps:

Buttons
1. Select ent r yBox in the Browser.

2. Inthe Resource Editor window, click on the text ent r yBox to the right of the label
“Instance Name”

Type the new name ent r yEdi t or .

4. Modify the following resources:

Resource Value Location

cancelLabelString [ Cancel| App
okLabelString OK App

(%)

Note: Entering text in the cancel Label Stri ng and okLabel St ri ng resources
automatically adds the respective buttons to the interface.

Final Formatting of ~ To change the title of the Entry Editor, perform the following steps:
Entry Editor
1. SelectentryEdit or inthe Browser.

Changing Entry 2. Setthedi al ogTi tl e resourceto Entry Edit or,with App resource
Editor title placement.

Adjusting Entry To do final adjustment of the layout of the address entry editor, perform the following
Editor Layout steps:
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1. SelectentryEdit or and all its children in the Browser by clicking on
ent r yEdi t or with Shift/MBI1. This selects the immediate item and all its children.
2. Select Natural Size on the Main Window Edit menu. This allows all the items in the
address entry editor to fit together smoothly.

Hint: If you are resizing a large number of objects, it can be quicker to hide the objects
before you do the resizing, since Builder Xcessory does not have to modify the screen for
each change. To hide a group of objects, click on the folder icon by the parent object in
the Browser tree.

The address Entry Editor should now appear like the following figure:
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SAVING THE INTERFACE
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Saving the Interface

Select Save from the File menu in the Main Window, then click OK.

This writes out the file ui | . ui | , which can be read back into Builder Xcessory to

4

reconstruct the collection. You can also rename the UIL file at this point, for example, to

tutorial _4.uil.
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SumMmMARY

Summary

ICS TUTORIALS

You have now completed Tutorial Four. In this tutorial, you have:

¢ Added a menu to your interface

*  Added items to a menu

*  Labeled menu items

*  Created mnemonics for menu items

*  Used Keep Parent to add multiple children to a widget
* Added a dialog to your interface

»  Customized a standard dialog box
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